shipyard中文版安装教程(附安装脚本)

一、 Docker Shipyard是什么 ?

shipyard是一个开源的docker管理平台,其特性主要包括:

  • 支持节点动态集群,可扩展节点的规模(swarm、etcd方案)
  • 支持镜像管理、容器管理、节点管理等功能
  • 可视化的容器管理和监控管理
  • 在线容器console终端

二、 Shipyard中文版源码托管在github(传送门)。

1.登陆界面 1.png

2.容器列表 2.png

3.容器信息创建 3.png

4.容器信息 4.png

5.终端连接 5.png

6.镜像信息 6.png

7.节点信息 7.png

8.仓库信息 8.png

三、shipyard中文版安装(CentOS)

  • 注:本文安装操作均在root用户下,安装前需先安装Docker (传送门)
  1. 下载所需docker镜像

    docker pull rethinkdb
    docker pull microbox/etcd
    docker pull shipyard/docker-proxy
    docker pull swarm
    docker pull dockerclub/shipyard
  2. 修改原安装脚本为中文版安装脚本

    #下载官方脚本
    wget https://shipyard-project.com/deploy
    若下载失败请使用
    wget https://raw.githubusercontent.com/shipyard/shipyard- 
    project.com/master/site/themes/shipyard/static/deploy
    
    #替换官方脚本
    grep -n shipyard:latest deploy
    sed -i 's/shipyard\/shipyard:latest/dockerclub\/shipyard:latest/g' deploy
  3. 设置web访问端口(根据需要修改)

    #检查8080端口是否被占用,若占用需修改端口
    yum install -y net-tools    //安装net-tools工具包,若已安装可跳过此步骤
    netstat -tlnp | grep 8080   //查看宿主机8080端口是否被占用
    #配置修改
    grep -n 'PORT:-8080' deploy
    SHIPYARD_PORT=${PORT:-8080}
    修改为
    SHIPYARD_PORT=${PORT:-指定端口}
  4. 安装与删除

    sh deploy                                //安装
    cat deploy | ACTION=remove bash          //删除
  5. 使用shipyard

    浏览器输入:http://主机IP:8080
    默认账号:admin
    默认密码:shipyard
  6. 安装过程中错误,常用的解决办法 容器冲突:

    #出现错误一般都是提示容器冲突,如果刚搭建,可以直接把容器全部停止并删除
    docker stop $(docker ps -a -q)        //停止所有服务
    docker rm $(docker ps -a -q)          //删除所有服务
    
    #也可以根据提示来找到容器的ID进行停止删除
    docker ps -a
    docker stop ID
    docker rm ID

四、 如何使用

  1. 如何增加一个节点
    curl https://shipyard-project.com/deploy | ACTION=node DISCOVERY=etcd://主服务器IP:4001 bash 
    若下载失败请使用
    curl -sSL  https://raw.githubusercontent.com/shipyard/shipyard-project.com/master/site/themes/shipyard/static/deploy | ACTION=node DISCOVERY=etcd://主节点IP:4001 bash -s

五、安装脚本下载

  1. 文件说明
    install.sh      //一键安装脚本
    deploy          //官方安装脚本修改版,若已下载前文所需镜像可直接运行此脚本安装
  2. 脚本下载:shipyard.tar.gz
  3. 注:作者由于没有时间与精力继续维护下去,在去年八月份就开始询问是否有人感兴趣接手该项目,可惜过了几个月依旧没有人出现,只能无奈的决定停止这个项目,官网也被关掉了。若下载安装失败请尝试替换下载链接为https://raw.githubusercontent.com/shipyard/shipyard-project.com/master/site/themes/shipyard/static/deploy
    参考文章:Centos-Docker-shipyard中文版安装
最后修改:2019 年 06 月 20 日 09 : 48 PM
如果觉得我的文章对你有用,请随意赞赏

30 条评论

  1. alva

    博主,你这遍文章太给力了,安装的那个脚本点赞

    1. hanblog
      @alva

      谢谢!

  2. 王不二

    我试了很多次,别的都正常,就是没有node,主节点装完后node不显示,加入node也不显示

    1. hanblog
      @王不二

      多节点的我没有测试过,且该项目原作者已弃坑,建议使用其他docker管理系统

  3. 刘生

    大神,我一直卡在这个界面,重复试过好几次都是卡在这里,不知道是什么原因 ,端口没有占用。

    root@ubuntu:~# sh deploy
    Deploying Shipyard
    -> Starting Database
    -> Starting Discovery
    -> Starting Cert Volume
    -> Starting Proxy
    -> Starting Swarm Manager
    -> Starting Swarm Agent
    -> Starting Controller
    Waiting for Shipyard on 192.168.85.128:8080

    1. hanblog
      @刘生

      你好,我这个脚本是基于Centos7写的,ubuntu未做适配,你可以按思路手动安装呢

    2. 刘生
      @刘生

      整个安装过程中没有任何报错,一共有7个容器在运行,就是服务起不来……(╯‵□′)╯︵┴─┴

      1. hanblog
        @刘生

        检查下是不是端口什么的冲突,然后检查下服务

        1. 刘生
          @hanblog

          十分感谢 。我看了你的脚本,最后一步启服务没有太看明白。

  4. 刘生

    这是个好东西,感谢博主分享。

    1. hanblog
      @刘生

      不谢呢,只是很遗憾这个工具作者已经弃坑了

  5. 孙伟

    为啥我启动后,界面上看不到任何的容器和镜像

    1. hanblog
      @孙伟

      你看下安装报错没有,正常情况是显示有几个容器运行的,还有就是这个项目原作者已停止开发,官网已关闭,可能导致部分镜像或组件下载失败

  6. Pseudo

    Centos下wget https://shipyard-project.com/deploy提示无法解析

    1. hanblog
      @Pseudo

      作者由于没有时间与精力继续维护下去,在去年八月份就开始询问是否有人感兴趣接手这个项目,可惜过了几个月依旧没有人出现,只能无奈的决定停止这个项目,官网也被关掉了。请将先前的官网链接替换为github链接:https://raw.githubusercontent.com/shipyard/shipyard-project.com/master/site/themes/shipyard/static/deploy试下呢

  7. 啊啊啊

    请问你的docker 版本 和 操作系统是什么?我是用的centos7 最新的docker版本。新版本仓库的地址不都是http://localhost:5000/v2/_catalog 这样访问的么。。或者方便的话 可不可以 给个 你可以用的镜像的下载链接呀,423308591@qq.com 感谢

    1. hanblog
      @啊啊啊

      https://www.fcwys.cc/index.php/archives/140.html
      我用的这个,centos7和docker-ce

    2. 啊啊啊
      @啊啊啊

      - - 不知道为什么这个回复 老是提交失败。我是那个阿斯达

      1. 风吹我已散
        @啊啊啊

        CDN出了点问题,已经修复,抱歉了

      2. hanblog
        @啊啊啊

        可以尝试重装一下

  8. zhuxinli

    你好,提示不是二进制文件

    1. hanblog
      @zhuxinli

      文件链接已修复,谢谢反馈,建议使用Linux下wget直接下载

      1. 阿斯达
        @hanblog

        请问 我添加仓库 报错 Get 10.6.11.233:5000/v1/search: unsupported protocol scheme "" 这个怎么办 我搜了下 似乎需要重新build controller 。但是build 报错 请问你是怎么解决的

        1. hanblog
          @阿斯达

          我没有遇到过这个问题呢,你可以尝试重建一下呢

  9. Damo

    能发个完整版的改好的中文版的安装脚本么?171679803@qq.com 麻烦了!请指点!

    1. michael
      @Damo

      你好, 方便共享一下你已经搞好的支持V2的镜像吗

      1. hanblog
        @michael

        你好,已经没有弄这个了,且作者已弃坑,抱歉呢,建议你使用k8s或其他管理平台呢

    2. hanblog
      @Damo

      已发送

  10. Damo

    楼主,问个问题,运行安装脚本为何提示无法执行二进制文件啊

    1. hanblog
      @Damo

      文件链接已修复,谢谢反馈,建议使用Linux下wget直接下载

发表评论